Road Star Warrior Forum : Yamaha Star Warrior Forums - View Single Post - Clutch Issues Maybe?
View Single Post
Old 08-12-2019, 09:06 PM   #8 (permalink)
rij1
Senior Member
 
rij1's Avatar
 
Join Date: Sep 2013
Location: From Whittier,California Live in Ventura,California
Posts: 2,350
Default

Quote:
Originally Posted by Zmann View Post
I adjusted the clutch and unfortunately everything is the same as before. I took a video of what it sounds like and will try to attach it below but I'm not sure how this will go...

https://youtu.be/zMKg-wVlXOY
Ahh, well that's not cable adjustment issue.
Is the bike in gear and clutch released and no movement?
Or in gear and lightly releasing clutch lever and the noise?

From the sounds of it either way, you may have to open up and inspect the clutch.
__________________

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

2002 XV1700 Roadstar Warrior
My Mods

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

BUB CHAMBERMAIDS

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

Riding On the Darkside #2 (235/45/ZR17 BFGoodrich G-Force Comp-2 A/S)
Rudy Jeremias.
(562)303-6036
rij1 is offline   Reply With Quote