RS Warrior Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
I just bought a 01 warrior in great shape. The story was is sat for 7 years , the guy I got it from said he put a new carb on, got it running rode it around but it wouldn’t idle and would rev up high in its own. It sat for a year, I got it did a quick float and bowl cleaning got it running and it’s pushing gas out of the overflow tube, won’t idle and revs high to a idle. So, the guy put a new carb , a new cdi box on which now makes me think this was doing this prior to these parts. It does slightly pop through the carb here and there but I think that’s from the excessive gas. What can I do here to fix this? Do you think it’s an air leak . It sounds good so I don’t think it’s something internal. Should I check the timing?
 

·
Registered
Joined
·
3 Posts
Discussion Starter #2
I just bought a 01 warrior in great shape. The story was is sat for 7 years , the guy I got it from said he put a new carb on, got it running rode it around but it wouldn’t idle and would rev up high in its own. It sat for a year, I got it, did a quick float and bowl cleaning got it running and it’s pushing gas out of the overflow tube, and it wouldn’t idle and would rev up and down. I re-cleaned the carb and got it to stop pushing gas out. But it idles at a high rpm and will very slightly rev up and down. Also, it seems like it will pop through the carb a tiny bit here and there. Am I looking more at a air leak or a bent valve or stuck valve?
 

·
Registered
Joined
·
965 Posts
You have 4 wheeler. This forum is for the Yamaha Road Star Warrior MOTORCYCLE.

Good luck in your repairs

Sent from my SAMSUNG-SM-G930A using Tapatalk
 

·
Registered
Joined
·
57 Posts
I just bought a 01 warrior in great shape. The story was is sat for 7 years , the guy I got it from said he put a new carb on, got it running rode it around but it wouldn’t idle and would rev up high in its own. It sat for a year, I got it did a quick float and bowl cleaning got it running and it’s pushing gas out of the overflow tube, won’t idle and revs high to a idle. So, the guy put a new carb , a new cdi box on which now makes me think this was doing this prior to these parts. It does slightly pop through the carb here and there but I think that’s from the excessive gas. What can I do here to fix this? Do you think it’s an air leak . It sounds good so I don’t think it’s something internal. Should I check the timing?
This site is for motor cycles bro not quads!
 

·
Registered
Joined
·
376 Posts
I was scratching my head with the 01 warrior, then remembered the quad lol oh well at least someone put him on the right path.
 
1 - 7 of 7 Posts
Top