RS Warrior Forum banner

1 - 20 of 28 Posts

·
Registered
Joined
·
14 Posts
Discussion Starter · #1 ·
Hello everyone I’m new to this and have only had my warrior for just a hair over a year, I have an issue that hopefully y’all can help me with. When I start the bike for the first time of any day it starts right up then dies within seconds. Then I restart it and give a lil gas and that issue goes away. Why is doing this?
 

·
Administrator
Joined
·
30,376 Posts
Welcome aboard!

When you cold start it, do a test by holding a very small amount of throttle to raise rpm slightly on first start, and hold it about 10~15 seconds and then release throttle, then let us know your results. For clarity, don't cold start without a little extra throttle, and keep the slightly higher rpm steady, don't play with the throttle. We are testing to see if perhaps the Linear Control Valve (LCV) has been removed.

Post a few bike pics! If you have some under the rider seat, and some under the tank, post those too! Let us see your Beast!
 

·
Administrator
Joined
·
30,376 Posts
Because the bike starts and runs your fuses should be okay including the 10 amp ECU fuse that also powers the LCV assuming it is still connected. I would expect warming weather season to make starting easier not harder, so weather changes are probably not the culprit.

We need several pictures under the tank and under the seat.

Also verify the ground lug under the rider seat near the oil filler between the ECU fuse.

253357


Separate from those, are there any error codes showing in the gauge when you shut the motor off with the handkebar kill switch.

Also still my first suggestions need answers. 😀
 

·
Administrator
Joined
·
30,376 Posts
You have a hot rod midnight Warrior with Speedstar 2-1-2 Gen2 exhaust and Speedstar right side intake air scoop. Stock ignition coils. The chrome handlebar risers are screaming to be powdercoated the same shade of midnight color too. Very very nasty looking beast. Congratulations!
 

·
Registered
Joined
·
14 Posts
Discussion Starter · #6 ·
Ok i will take a pic under the seat really quick and wait to do your test when I first start in the morning. No warning lights come on at all. After the first start of the day and after the quick stall after start the rest of the day is no issue
 

·
Registered
Joined
·
14 Posts
Discussion Starter · #7 ·
Ok i will take a pic under the seat really quick and wait to do your test when I first start in the morning. No warning lights come on at all. After the first start of the day and after the quick stall after start the rest of the day is no issue
 

Attachments

·
Premium Member
Joined
·
1,926 Posts
Here’s my favorite pic. So under my gas tank is 2 stacks. I have searched but don’t have a power commander. I believe that the ecu was flashed. This stalling upon the first start of the day has just recently started to happen
How'd you get your Speedstar exhaust to be so shiny? Looks great!
 

·
Administrator
Joined
·
30,376 Posts
Okay. You have the Speedstar ECU. It appears the stock silencer airbox is still under the tank, but might be topless and might contain the Speedstar big air kit (gotta pull the tank for pics!).

I cannot quite see the fuel injectors to know if they are also Speedstar. They are behind the scoop.
 

·
Registered
Joined
·
14 Posts
Discussion Starter · #12 ·
Yes. 5PX70 indicates Speedstar ECU. Hot.
Is that good lol
Okay. You have the Speedstar ECU. It appears the stock silencer airbox is still under the tank, but might be topless and might contain the Speedstar big air kit (gotta pull the tank for pics!).

I cannot quite see the fuel injectors to know if they are also Speedstar. They are behind the scoop.
ok I’ll pull tank quick I have a few mins free
 

·
Premium Member
Joined
·
1,926 Posts
Thank you it’s a gloss black powder coat
How long has it been like that and have you had any issues? I ended up doing Cerakote with the Glacier Black but it's a bit more matte than I was hoping. I've heard of guys doing gloss VHT but am not sure if I want to go that route.
253361
 

·
Administrator
Joined
·
30,376 Posts
Here’s my favorite pic. So under my gas tank is 2 stacks. I have searched but don’t have a power commander. I believe that the ecu was flashed. This stalling upon the first start of the day has just recently started to happen
Okay the two stacks are probably Speedstar intakes but need pics to know. They could be in a topless box, or naked which is preferred for air gulping. This picture is critical to know about filtration.

Correct you don't have an aftermarket fuel manager, which is supported by underseat pictures showing no unit stuffed on top of the auxiliary fuel tank plus no extra wires at the ground lug near the oil filler cap. The Speedstar ECU has the hot fuel map in it.

I'd like to get my hand on that bad boy for a couple hours in the mountains and give it back to you with razor-sharp ground-down rider foot pegs and just fumes in the gas tanks lol.
 

·
Registered
Joined
·
14 Posts
Discussion Starter · #16 ·
Okay the two stacks are probably Speedstar intakes but need pics to know. They could be in a topless box, or naked which is preferred for air gulping. This picture is critical to know about filtration.

Correct you don't have an aftermarket fuel manager, which is supported by underseat pictures showing no unit stuffed on top of the auxiliary fuel tank plus no extra wires at the ground lug near the oil filler cap. The Speedstar ECU has the hot fuel map in it.

I'd like to get my hand on that bad boy for a couple hours in the mountains and give it back to you with razor-sharp ground-down rider foot pegs and just fumes in the gas tanks lol.
Lmfao do it. Come see her in upstate NY she’ll b ready for ya just under 12k miles on it.
 

·
Administrator
Joined
·
30,376 Posts
Yep just finished. Those are race track stacks, unfiltered and gritty, its chewing up the Cylinders. Look great work crummy.

Contact Churchkey here. He builds VBAK kits designed for this bike. You get filtration and big air. Ask him to upgrade you to RC1290 K&N's. If he does not do that anymore then first air filter change go to K&N RC1290's you'll feel the difference.

What we still don't know is if your Beast has S* pistons and valve springs and cams and fuel injectors. If you send me your bike's VIN off the steering neck AND the Engine ID off the block I'll see if I can identify if the S* motor mods were done at the factory. Also if there is a white sticker on the ECU opposite side send that too.

If no paper trail then the motor mods were done by a dealer or maybe by a savvy owner. You can manually check. Let's cross that bridge if/when we get to it.

Exciting stuff.
 
1 - 20 of 28 Posts
Top