RS Warrior Forum banner
1 - 9 of 9 Posts

·
Super Moderator
'05 Midnight
Joined
·
3,506 Posts
Hi! Welcome from Southern California!

Nasty mean looking machine you've got there!! I LOVE the pipe tips! Would love to hear a sound clip of them if you have one (post on Youtube and link using Media in the post).

I hate to ask, but could you explain a little clearer what the issue is, specifically this part, "now pull the clutch, seems ok, gear engages and stall, no clutch , cable then clutch"? Is she dying when you put her in gear? Can you put into gear and then take her back to neutral ok? When manually pushing, does she free-roll while in gear? Just trying to be clear so we understand what the issue is.
 

·
Registered
Joined
·
2,694 Posts
It sounds like the clutch plates have stuck together. I had the same problem, I started bike after it had been stood for a while put it in gear with the clutch lever held in and the bike lunged forward as if clutch lever had been released. The bike stalled so I put it back in neutral gear started the engine and the bike lunged forward again and stalled with the clutch lever held in again. So i rolled the bike down a slight decline turned the bike round so it was pointing up the hill, started the engine in neutral with a few revs put bike in 2 nd gear, the bike shot forward and the clutch this time released. Worked for me, but be careful make sure you have plenty of space. 👍. Frec 🇬🇧
 

·
Registered
Joined
·
5 Posts
Hi,
My 03 warrior, been off road for nearly 4yrs, now pull the clutch, seems ok, gear engages and stall, no clutch , cable then clutch. She's done 41k miles, I have done everything to keep her healthy.
First post, I have put pics on

Just a thought...
It's not so simple as the kick stand sensor sticking or faulty? Bike doesn't know the kickstand is up? Especially if it sat four years and wasn't raised and lowered regularly? Spray it down and "excercise" that stand's switch.
 

·
[Retired Admin-SuperMod]
Joined
·
31,870 Posts
Hi,
My 03 warrior, been off road for nearly 4yrs, now pull the clutch, seems ok, gear engages and stall, no clutch , cable then clutch. She's done 41k miles, I have done everything to keep her healthy.
First post, I have put pics on
Fact is that I can read and understand what you have written several different ways. So confused. You might be better served to clarify by using separate sentences for separate observations and symptoms. From your original post (op) it's not very possible to suggest a course of action. Some suggestions here could work, but since I think you mean to say the bike starts with the clutch lever pulled-in then it stalls when you release the clutch lever (?) It's possible some suggestions might not help. But it's not clear.
 

·
Registered
Joined
·
5,368 Posts
It sounds to me that the bike has been sitting for 4 years and I'd bet good money that the plates are stuck together. But that is just my best guess.
 
  • Like
Reactions: arizonawarrior

·
[Retired Admin-SuperMod]
Joined
·
31,870 Posts
Entirely possible. Put the front wheel against a wall and dump the clutch and light it up, right! Okay I know it's safer to motor-off roll the bike and dump the clutch. It'll break free. But not as much fun!
 

·
Registered
Joined
·
5,368 Posts
Entirely possible. Put the front wheel against a wall and dump the clutch and light it up, right! Okay I know it's safer to motor-off roll the bike and dump the clutch. It'll break free. But not as much fun!
Well, the problem with the clutch plates sticking is even with the motor off and clutch pulled in, it won't roll anywhere while in gear as the plates are stuck together. What I've done in the past on a few different bikes is with the bike off, work the transmission into the highest gear that the bike has, pull the clutch in and have a buddy help me rock it back and forth. With the transmission in the tallest gear it puts the clutch at the biggest mechanical disadvantage and is easier to unstick.
 
1 - 9 of 9 Posts
Top