RS Warrior Forum banner

1 - 13 of 13 Posts

·
Registered
Joined
·
89 Posts
Discussion Starter #1
Has anyone had the recall done and found that the beast just dies at idle...just flat out goes dead....I've never had this happen before..but its happening now...had the recall done about 3 weeks ago....
 

·
Registered
Joined
·
2,938 Posts
Is your bike cold when you pull in the clutch and it dies??


If so i think it is pretty normal. Mine does it sometimes too. Just blip the the throttle when the bikes is cold, and coming up to a stop sign with the clutch pulled in.

But if it does it when warm, i have no idea!![?]
 

·
Registered
Joined
·
5,457 Posts
mine would do that when the clutch was too tight....it would slightly drag when I pulled in the clutch...enough to stall the engine. Quick adjustment per the owners manual and all was well. Also, make sure your idle is at least 900-950.
 

·
Registered
Joined
·
215 Posts
Man!! So many probs after the re-call!!Glad alot of us didn't do it!!!Seems to be a waste and the bike runs like crap after....Here's a "Cold One " to all of the Warrior riders with 20,000 or more who never did the recall!!!
 

·
Registered
Joined
·
5,457 Posts
quote:Originally posted by jake

Man!! So many probs after the re-call!!Glad alot of us didn't do it!!!Seems to be a waste and the bike runs like crap after....Here's a "Cold One " to all of the Warrior riders with 20,000 or more who never did the recall!!!


Please tell me you're not serious.... You'll wish you did it if your CPS goes out on the side of the road...Here's a "Cold One" to everyone who wakes up and get's it done because there's no reason not too.

BTW, resetting the PCIII is the only suggestion that would be related to having the recalls done. The other things are common solutions for his symptoms and have nothing to do with the fact that the recalls were done. But, I don't think he has a PCIII unless he didn't list it in his gallery so I bet his problem is unrelated.
 

·
Registered
Joined
·
1,396 Posts
I have had to bike die before, but I adjusted the map manually in the 0 throttle position to 10 at all rpm's and it took care of it.
 

·
Registered
Joined
·
38 Posts
i had 24000 miles on mine,i had set up appointment ,cps died on friday before it ,could not get it fixed until tuesday. another weekend lost to riding. i'd get it done. when mine went i was coming home from work after 14.5 hr day and i did not need that problem that night.
 

·
Registered
Joined
·
122 Posts
had mine done about two weeks ago unloaded from truck started up and rode to end of road died twice i thought that i would have to take back to dealer got home warmed it up good and it ran like a bat out of ****! got to love these torque monsters!
 
1 - 13 of 13 Posts
Top