RS Warrior Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter #1
Hi guys I need help with my Warrior, the battery is draining me, I read that if they changed the front turn signals, I had that problem, install the originals, there is some part that sends current to the ground, I have a reading between the chassis and the negative of the battery, but no fuse blows
 

·
Administrator
Joined
·
28,191 Posts
Welcome aboard Joel!

Read-up on Click of Death (COD) to see if it seems to fit your conditions. If the stock front RUNNING LIGHTS have been removed (the front turn signals are shared with the front running lights in a 2-filament bulb) AND if the stock license plate light has been removed, then COD most often results. Lots of ink on this.
 

·
Registered
Joined
·
231 Posts
Hey Joel, welcome to the forum. AZ is right there has been a lot written about the Click of Death. Also YouTube has a good solution for that problem. Go into YouTube search for RS WARRIOR and Bryan shows you a quick and simple fix. The other advice is use the key to shut the bike off and not the kill switch. I hope that helps.
 

·
Registered
Joined
·
4 Posts
Discussion Starter #5
I installed an incandescent light bulb on the wire using the blue and black wire but still with the problem
 

·
Premium Member
Joined
·
8,718 Posts
I installed an incandescent light bulb on the wire using the blue and black wire but still with the problem
Here's a couple of real world solutions to patch the COD by this writer if intersted:
 
1 - 7 of 7 Posts
Top