RS Warrior Forum banner

1 - 13 of 13 Posts

·
Registered
Joined
·
22 Posts
Discussion Starter #1
My low fuel light came on last week at about 100 miles on that tank of gas. I pulled into a gas station and filled up and then went across the street and ate lunch. When I left and got back on the road, the fuel light was still on. I figured that it would go off soon, so I ignored it. Well I've ridden it twice since then (total of about 50 miles) and it is still on. Anyone have any ideas?[?]
 

·
Registered
Joined
·
872 Posts
This happened to me but it was an issue of air in the fuel lines. It stoped the bike cold. Had to get a tow back to the dealership. It really sucked.
 

·
Registered
Joined
·
775 Posts
quote:Originally posted by Cult_of_Speed

This happened to me but it was an issue of air in the fuel lines. It stoped the bike cold. Had to get a tow back to the dealership. It really sucked.

I think, a trip to the dealer will be the best option wile the bike still running ,Will be not funny to get no engine in no where land and have to tow that baby.[/emoticons/emotion-6.gif]
Alek5
 

·
Super Moderator
Joined
·
13,703 Posts
Check the one under the scoop and the big one under the seat. Happened to me too. Disconnect and reconnect them a few times even if they feel tight. When I pushed on the one under my seat I heard a click and then everything was fine.
 

·
Registered
Joined
·
872 Posts
Yeah...it really sucked. I had Joe Bob and BIlly Bob's towing all manhandling my baby to the dealer and ****...Left me on the side of the road all with only 33 miles on the OD even though I had just filled the tank when I left the dealer.
I was HOT! So...check it out...get it to the dealer....it is bad enough to have the dealer's boys manhandle the bike let alone Joe Bob and Billy.
 

·
Registered
Joined
·
579 Posts
Again connector under scoop, mind vibrated loose and I ran out of gas on the highway. I had a full top tank so I kind of knew what to look for thank god the tool kit had a 5mm allen /emoticons/emotion-5.gif

If you got 50 miles on you are feeding to the lower tank, you should only be able to go about 25 if the feed from the top tank wasn't working.
 

·
Registered
Joined
·
22 Posts
Discussion Starter #13
You guys as gawds. The connect under the seat was not tight. I pushed it in and it snapped in place. That was the problem. Thanks.
 
1 - 13 of 13 Posts
Top