RS Warrior Forum banner
1 - 5 of 5 Posts

·
Registered
Joined
·
15 Posts
Discussion Starter · #1 ·
I was driving yesterday and this fule line blew off. It was the upper one I finally found out what happened and just pushed the clip back over the rib on the line and pulled on it a couple of times seems secure now. Anyone have any ideas why it happened? 1624070455237.png
 

·
[Retired Admin-SuperMod]
Joined
·
30,562 Posts
I've thought about this for the past day since seeing this post. I cannot recall seeing this fuel line come loose. These type of clips seem to work really well and this one is tucked-in nicely. I imagine that if someone were to reach in there for some surrounding purpose it's possible to have unknowingly loosed the clip.
 

·
Registered
Joined
·
15 Posts
Discussion Starter · #3 ·
I've thought about this for the past day since seeing this post. I cannot recall seeing this fuel line come loose. These type of clips seem to work really well and this one is tucked-in nicely. I imagine that if someone were to reach in there for some surrounding purpose it's possible to have unknowingly loosed the clip.
Yeah it’s weird it’s behind the left side cover and I’ve put over 5000 miles on it with no issues before
 

·
Registered
Joined
·
7,929 Posts
Odd that I should find this post. I had the clip on the back line came loose last week. The hose connection on the tank for the under seat dry break came off. My bike was belching fuel through the hose end. I was able to find the clip, replace the line and all seems fine. I had just cleaned and recharged the K&N filters of my churchkey BAK. I think somehow I may have caused the clamp to come off during reinstalling the gas tank.
 
1 - 5 of 5 Posts
Top