RS Warrior Forum banner
1 - 4 of 4 Posts

·
Registered
Joined
·
692 Posts
Discussion Starter · #1 ·
Received myPCIII today, been looking over the instructions and pouring over the posts about the "Perfect Install". Based on what I have seen and read regarding the perfect install the PCIII wiring harness has a ring terminal that has a black wire and a black/white wire that come out of the harness and terminate at he ring terminal. See pic that I pulled from REDHORSES thread



Based on what I have read the perfect install method is to cut the black/white wire and splice it into the bikes current wiring harness



My PCIII which I just pulled out of the box only has 1 wire - the black one coming out of the harness and terminating with a ring terminal.





I see no black/white wire. Does this mean I have the latest version of the PCIII which doesn't require the perfect install method? I don't want to start chopping stuff up if I don't have to
 

·
Registered
Joined
·
55 Posts
You won't need to do the 'perfect' Install if you have the new TPS (throttle positioning sensor)plug. I bought my PCIII in July and ithad the new TPS plug.
 

·
Registered
Joined
·
692 Posts
Discussion Starter · #4 ·
Argh, now I have to wait till I get home from workto check, but if I recall my harness matches the picture provided by phat-azz so fairly certain I have the new TPS plug.


Appreciate the info, there is such a wealth of knowledge on this site that sometimes it's hard to find the info you are looking for using the search function
 
1 - 4 of 4 Posts
Top