RS Warrior Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
14 Posts
Discussion Starter #1
Seeking help and the knowledge of you guys....I disconnected the hose to empty my fuel tank after draining the old fuel out I reconnected the hose and fill the tank up with fresh new gas. The problem is now that the bike idles really bad and low and then it dies. If I hold the throttle it sounds strange but if I let go it dies. I not an expert, any insight will be greatly appreciated. Thanks
 

·
Registered
Joined
·
14 Posts
Discussion Starter #3
It was actually the behind the cover. that was the only one I removed to empty the tank
 

·
Registered
Joined
·
1,502 Posts
Try spraying the inside of the connectors with WD-40 and when you re-connect make sure you get a nice click.
 

·
Administrator
Joined
·
28,594 Posts
Okay so you emptied the top main tank. But not the underseat tank. I agree with Stretch its probably good to start with the dry break is not lubed so did not click together all the way. Or the vent hose got crimped between the frame and the underside of the top fuel tank on re-install. Let us know if that helps you, okay?
 

·
Registered
Joined
·
14 Posts
Discussion Starter #6
ill try that, also is there a way to empty the reserve tank so all fuel is fresh?
 

·
Administrator
Joined
·
28,594 Posts
Yes. There is a high pressure hose right side, disconnect it at joint then turn key to spray fuel into a bonfire (or a safe container lol).

Plenty of posts and threads on this so will not add another. When searching, use criteria something like 'how to empty bottom underseat fuel tank."
 
1 - 7 of 7 Posts
Top