RS Warrior Forum banner

1 - 9 of 9 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
Hello all, I have an issue that is driving me crazy, I have an 06, and only, only when the engine gets hot, normal operating temp, the bike sputters, and jerks, and when In neutral, it will die, I’ve changed plugs, fuel pump and battery, I’m leaning towards coils, but want to check first before putting unnecessary money into it. Thanks a million!!!!!
 

·
Premium Member
Joined
·
5,607 Posts
Hello all, I have an issue that is driving me crazy, I have an 06, and only, only when the engine gets hot, normal operating temp, the bike sputters, and jerks, and when In neutral, it will die, I’ve changed plugs, fuel pump and battery, I’m leaning towards coils, but want to check first before putting unnecessary money into it. Thanks a million!!!!!
I don't know what you have done to the bike because you have not listed anything in your profile but i believe that after the bike warms up your fuel settings are probably off. A power commander or some sort of fuel management might need to be added. Just guessing at this point.
 

·
Registered
Joined
·
36 Posts
Hey Talon, I have had some similar issues with my bike. My issues only show up when the bike get super hot. Here is a link to my forum thread about it https://www.rswarrior.com/forums/13-technical-discussion/304792-loss-power-low-rpm-acceleration.html

From what others have told me on here and what I've read, it could be my LCV (Linear control valve), CPS (Crank position sensor), LAS (Lean angle sensor) or maybe a coil. So I will definitely be following this thread to see if you get it figured out. Best/ only thing you can do is trouble shoot one item at a time and go out for a ride to test. Good luck.
 

·
Premium Member
Joined
·
2,972 Posts
Talon list your mods and what you have done to the bike. More info the better.....
Have you checked for vacuum leaks?
 

·
Registered
Joined
·
6,346 Posts
Honestly think you alrdy spent unnecessary money....On the fuel pump and so ..
I always come here b4 I start replacing parts.

Like suggested post info about ur M/C
So we can help u out....

Sent from my SAMSUNG-SM-J327A using Tapatalk
 
1 - 9 of 9 Posts
Top