RS Warrior Forum banner

1 - 15 of 15 Posts

·
Registered
Joined
·
511 Posts
Discussion Starter #1
Hi I have a 2002 with barons big air kit v&h big shots pc5 the bike just started skipping somewhat while riding it especially cruising, it does this at random times random rpms and random gears, seems to idle fine and sometimes I can rev it and it will fix it for a bit, it doesn?t always do it but it seems to get worse I have changed plugs and checked vacuum with no luck and a side note it acted just like this one other time when my battery cable was loose although this time they are tight and I replaced the battery hoping it would fix my issue no luck so far.
 

·
Registered
Joined
·
8,215 Posts
Dyna coils?
Check the coils the primary leads can ground on the relocation plate.

Stock coils primary wires (the small ones): squeeze the female connectors a bit they need to be tight on the coil blades.

Spark plug boots screw onto the plug wires insure they are tight.

BTW If the crank position sensor is failing @ 3000 rpm the engine will struggle to run.
 

·
Registered
Joined
·
511 Posts
Discussion Starter #3
I have stock coils, I will check the leads after work, the plug wires I just pressed on didn?t screw on could that be the issue? Thank you for your fast reply also is there a way to test a failing CPS withought pulling the cover?
 

·
Registered
Joined
·
511 Posts
Discussion Starter #4
Ok so update I took it for a small ride and it actually did it at low rpm today and when it did I could hear what sounded like a poof from my front left side of the bike but not 100% sure any thoughts on that?
 

·
Registered
Joined
·
511 Posts
Discussion Starter #5
So new update I pulled all my led under lights off to clean up wires under seat and tank, checked all grounds, all plugs, coil plugs nothing corroded but it was dirty from the ride back from Myrtle beach bike rally Sunday anyway checked hoses everything looked good so upon my inspection noticed the rear right spark plug had over half the threads hanging out so I took it out worked it in and out till it bottomed our smoothly and put her all back together first think I noticed was if I barely blipped the throttle it didn?t try to die out also no skipping and felt STRONG I?m going for a long ride tomorrow to see if it really did fix my problem wish me luck
 

·
Registered
Joined
·
511 Posts
Discussion Starter #9
Thank you everyone for the friendly replies and fast help I?m glad to be a part of the warrior family
 

·
Registered
Joined
·
511 Posts
Discussion Starter #10
Bike is running great but I?m getting a poof out the intake at low rpm in first gear like coming down my driveway TB synth maybe?
 

·
Registered
Joined
·
823 Posts
Welcome to the forum. Could be idle set too low or lcv failed or deleted. Mine does that occasionally when cold and I have LCV delete.
 

·
Registered
Joined
·
511 Posts
Discussion Starter #12
I reset my idle up to 920 where it was at 600 not knowing these bikes need it that high till I read the forums, LCV as in the Fuel Injections choke system? Is it possible that the previous owner tuned the bike at a low idle to try to capture the lope sound and now with the idle up it?s either lean or rich?
 

·
Registered
Joined
·
823 Posts
LCV "Linear ? Control Valve" Yeah it acts like a choke. when the bike is cold, the ECU adds extra fuel and the LCV gives a little extra air so the bike idles appropriately until it comes up to temp. They have failed for a number of members, and others (like me) remove them to show more of the front cylinder, but not having it requires starting the bike a little differently.
there is a fair amount to be read here on the forum about it, I am certainly no expert.
 

·
Registered
Joined
·
511 Posts
Discussion Starter #14
I tested it out and after going down my driveway the same way I went up except after I?ve rode awhile it drove normal although through my ride when I had a weak throttle hand taking off it did pop accationally nothing terrible, I have noticed a lot more popping from the exhaust sense I put new plugs and a new vacuum cap over my throttle body nipple (the old one was split) and shifting gears but also it feels a lot stronger maybe it?s actually running right for a change?
 

·
Premium Member
Joined
·
5,858 Posts
welcome blackpearl ..indeed the 'family' here is strong ...

it's why i'm trying to get new guys on facebook to come visit and hopefully pull up a chair ...

it's the only place to find the gurus for every aspect of the warrior ...and the huge huge libraries and even the 500 page manual

facebook is just ok for a quick help moment and photos to see .... and to say hi of course
 
1 - 15 of 15 Posts
Top