RS Warrior Forum banner
1 - 5 of 5 Posts

·
Registered
Joined
·
370 Posts
Discussion Starter · #1 ·
Ok, I briefly touched on this a while ago but I made the adjustments to the clutch cable and it's tight as a drum now but when I hold the clutch in and have it in first it sounds like a loose fan belt on my first car. Whenever I'm moving forward and downshift to first gear the noise starts and doesn't go away until you put in neutral and let off the clutch or shift up to second gear.


Also, I bought a comp speed clutch spring off of Ebay and am wondering if it's possible to add more clutch plates or is just putting this thing on going to makea difference?
 

·
Registered
Joined
·
114 Posts
The clutch cable shouldn't be "tight as a drum" with the lever released. If you've taken all the slack out of the cable you may be experiencing a small amount of slippage under load.


The owner's manual and/or service manual has the spec for how much free play should be found at the clutch lever before it applies tension to the cable.
 

·
Registered
Joined
·
370 Posts
Discussion Starter · #3 ·
well ok, not literally drum tight, the clutch engages after about a half inch of lever squeeze and has a nice feel to it. About 2/3 of the squeeze is the clutch. I can feel it engage and disengage but still have a squeal. Was thinking maybe the bearing, but only get the sound in first gear.
 

·
Registered
Joined
·
370 Posts
Discussion Starter · #5 ·
YAMAHA PART # SPD-5PX09-84-00 Haven't installed it yet, just getting ready to this weekend.
 
1 - 5 of 5 Posts
Top