RS Warrior Forum banner
1 - 12 of 12 Posts

·
Registered
Joined
·
86 Posts
Discussion Starter · #1 ·
Recently I have run into a few problems with mike bike. One is out of no where I have been getting terrible gas milage. I just did the perfect pc3 install this weekend. Would this help correct this problem? Any suggestions on what it could be?
 

·
Registered
Joined
·
2,600 Posts
If you are suddenly getting crappy mileage, maybe you have a fuel leak somewhere. Check all the fuel lines...can you smell gas?? Does your tank have a pinhole leak? Are the dry breaks under the seat and under the left side cover properly seated?
 

·
Registered
Joined
·
999 Posts
The next time you fill up, do it before the fuel light comes on, and see what kind of mileage you get on that tank. If you fill up too fast, the tank doesnt fill completley, because the reserve tank takes time to fill. That leaves you with less fuel, on that fill up. Less fuel= less mileage.
 

·
Registered
Joined
·
4,938 Posts
Good point on making sure the fill up was actually full!.


Might suggest checking your plugs...if they are BLACK/***** then you are running super rich. Is she popping alot?? running crappy?? hows the power?
 

·
Registered
Joined
·
922 Posts
jgreen53 said:
Recently I have run into a few problems with mike bike. One is out of no where I have been getting terrible gas milage. I just did the perfect pc3 install this weekend. Would this help correct this problem? Any suggestions on what it could be?




Can you give us some more information.


What kind of mileage do you normallyget?


Has this been going onfor a whileor did you only notice it atthe last fill-up you made?


If this only happened once, how far did you go and how many gallons did you take to refill?
 

·
Registered
Joined
·
86 Posts
Discussion Starter · #9 ·
Well I had been getting some where between 98 and 110 miles before the fuel light came on. This is all based on in town milage and it would be between 2.7 and 2.9 gallons when I filled it up. The last 3 tanks of gas have gotten worse each time. The last tank before the perfect pc III instal was around 77 miles and it took 2.9 gallons to fill it up. The plugs are new, only a few months old and have less than a few thousand miles on them. I took them out this weekend just to see an nothing out of the ordinary. I checked all my conections including LCV hose connections, all fuel line fittings, AP conection, and air filters.

I am currently on the first tank of gas since the perfect pc III install so we will se how this tank goes.

I appriciate all the help.

J-man
 

·
[Retired Admin-SuperMod]
Joined
·
30,711 Posts
Are you buying name-brand gas at the same place each time? If yes, its probably not the quality of the gas, so maybe go out on the web and read-up about Summer Blend and Winter Blend Gasoline and see if it might contribute. Different states switch to winter blend at different times.
 

·
Registered
Joined
·
1,323 Posts
Make a copy of your map and save it. Then put all 0's in the map so you are basically back to no correction to the bikes stock map or just disconnect the PC. That will at least tell you if the PC is the problem.....
 

·
Registered
Joined
·
86 Posts
Discussion Starter · #12 ·
I reset the PC to Zero's and ran a tank of gas through it and the milage increased. Back to normal need a new PC III.

Know of any rebates through Dyno Jet since my old one took a S*$#?
+
=
 
1 - 12 of 12 Posts
Top