RS Warrior Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
26 Posts
Discussion Starter #1
So I read what everybody said to do in order to launch these bikes. Now I'm a noob to really launching, but I reved it to 2000rpm or so and popped the clutch and my rear end just shifted sideways from spinning and then I let off the gas and once it quite spinning I was able to carry on. So am I doing something wrong or what?
 

·
Registered
Joined
·
8,255 Posts
Feather the clutch out as throttle is applied when the clutch is all the way out the throttle should be pinned.

Ride for a few minutes between launches to cool the clutch plates.
 

·
Registered
Joined
·
203 Posts
Well at the track I launch at around 4500 rpm and it's one smooth motion. Let it out quick but make sure to keep up with the throttle as well and she will go like a bat outta **** my best 60' is a 1.5 doing it this way. Just need to be fluid with it don't dump it.


Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
1,013 Posts
Well at the track I launch at around 4500 rpm and it's one smooth motion. Let it out quick but make sure to keep up with the throttle as well and she will go like a bat outta **** my best 60' is a 1.5 doing it this way. Just need to be fluid with it don't dump it.


Sent from my iPhone using Tapatalk
1.5!!! Nice! My best 60' is a 1.8080. I try to launch about the same RPM, maybe 500 less. Looks like I need to work on it some more. What are you using for a back tire?
 
1 - 6 of 6 Posts
Top