RS Warrior Forum banner

6801 - 6820 of 6949 Posts

·
Premium Member
Joined
·
8,823 Posts
Past couple of days: Rebuilt Frt Brake Master Cyl with new piston kit and bleed-out Frt & Rear system with fresh DOT4.
Polish Frt & Rear Rotor Mounting Screws and protect with Dupli-Color Clear coat Finish to prevent corrosion. Used a M6 x 1.0p 4-flute tap to clean out the old thread-lock in the wheels as req'd as well as the companion M6 die to clean up the rotor bolt threads.
249013

249014

249011

249015

249016

249017

249018
 

·
Registered
Joined
·
38 Posts
Shiny! A good reminder that I need to get a good cleaning on. Rode out today for the first time in weeks and next ride needs to be a stop at the wash.


Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
6,750 Posts
Just finished putting the warrior back 2gther..
Front suspension seems firmer...
Will see on way 2 work 2mrw..
Seems that the front end sit higher..

Also new OE front pads...


Sent from my SM-A102U1 using Tapatalk
 

·
Premium Member
Joined
·
8,823 Posts
alanh, why DOT 4 brake fluid?
The Factory recommended brake fluid is DOT 4!
I replace the brake fluids every 2-yrs on the Warrior with the Pro Honda brand as shown below.
 

·
Registered
Joined
·
540 Posts
Well today Saturday ( 8:06am ) looks like a nice winters day so I just might go for a ride. I want to test out the new rubber mountings I have made for the bars and try out the new grips.
 

·
Registered
Joined
·
6,750 Posts
Well Took the warrior out ...
Quick lil run around...

Front end is all good...

Just [email protected] belt squeak...

I've adjusted belt tension thought I had it right, but thought wrong...



Sent from my SM-A102U1 using Tapatalk
 

·
Premium Member
Joined
·
5,661 Posts
Well Took the warrior out ...
Quick lil run around...

Front end is all good...

Just [email protected] belt squeak...

I've adjusted belt tension thought I had it right, but thought wrong...



Sent from my SM-A102U1 using Tapatalk
I have a custom rear pulley and it squeaks bad sometimes. I have resorted to using Redline assembly lube on the belt and it stops the squeak for a good while but over time it comes back, but is the best stuff so far for stopping the squeaks and it doesn't seem to affect the belts durability. Harley had a product but discontinued it but recommended the assembly lube. I just rub a little on the belt ribs and on the edge of the belt and that takes care of it. I have tried every adjustment you could make to no avail, so i resorted to the lube. Good luck with it.
 

·
Registered
Joined
·
1,385 Posts
After over five years I breathed fire into her, but now my turn signals ,and driving lights are not working properly Only one driving light,and one rear signal,and that is working on the wrong side. I would post a vid but for some reason I can't get it saved right to post.
 

·
Premium Member
Joined
·
5,661 Posts
Thnks Gilly..
Where c.a n I get that Redine stuff

Sent from my SM-A102U1 using Tapatalk
I imagine you could use most any assembly lube. I can't remember where i got the Redline. Might have to do a google search.
 

·
Registered
Joined
·
218 Posts
Changed gear oil, engine oil, installed led headlight bulb, properly adjusted clutch linkage and cable, adjusted sag preload front and rear for my weight of 1", checked belt tension. Tension came in at 5mm but not sure I want to remove the exhaust to adjust since its just a tad out of spec.

Long weekend and it's hot in my garage......

Sent from my SM-N950U using Tapatalk
 

·
Registered
Joined
·
705 Posts
Really enjoying my new Cobra Swept exhaust. They sound amazing and are killer looking. Everyone stares at them. I left the baffles in them so they don’t sound as good as my Rineharts but I’ll take the performance and looks any day!



Sent from my iPhone using Tapatalk
 
6801 - 6820 of 6949 Posts
Top